Topic: Silverlight 2

If you use plupload on a web browser with Silverlight 2 installed, it prompts you to upgrade to Silverlight 3. But the user can refuse, in which case the upload control will not work.
Ideally I think the Silverlight runtime should be ignored unless Silverlight 3 is installed. Is that possible?

Re: Silverlight 2

Yes, but it's better to try to force the users to upgrade. And if they are retarded enough to press cancel and then expecting it to still work then they deserve living without an upload feature. smile