1 (edited by dfrechette 2011-01-12 19:11:37)

Topic: Plupload & IE9 64-bit: no compatible runtimes?

Hello,

I just installed IE9 beta 64-bit edition and can't find any compatible runtimes for it (list of runtimes: 'gears,html5,flash,silverlight,browserplus').

I can't even see or run the Plupload demos (http://www.plupload.com/example_queuewidget.php) with IE.

My code works perfectly well with Firefox, Safari, Chrome and Opera using the latest version of Plupload (1.3.0).

Is anyone else experiencing the same problem? Any known fix/work around for it?

Thank you

Daniel

Re: Plupload & IE9 64-bit: no compatible runtimes?

Woa. Do you actually got flash or silverlight plugins installed on your brand new IE9 beta?

If you want to see your issue fixed, do not report it here, do it on - GitHub.

3 (edited by dfrechette 2011-01-12 21:07:37)

Re: Plupload & IE9 64-bit: no compatible runtimes?

I installed Flash Player "Square" preview release with native 64-bit support (http://labs.adobe.com/technologies/flas … 10/square/), but it does not work.

I did not find a 64-bit version of Silverlight.

Releasing IE9 64-bit with no compatible version of Silverlight (also from Microsoft) is simply unacceptable!!! A beta version of Silverlight 5 is expected to be available in Spring 2011.

Daniel

Re: Plupload & IE9 64-bit: no compatible runtimes?

Sounds like quite a problem. Hmm... Do not have 64-bit Windows (Windows 7, right?) here at the moment. But I remember trying it on there a while ago without any problem. Will recheck it these days.

You could always use HTML4 runtime as last resort.

If you want to see your issue fixed, do not report it here, do it on - GitHub.

5 (edited by dfrechette 2011-01-12 21:08:37)

Re: Plupload & IE9 64-bit: no compatible runtimes?

Yes, I am using Windows 7 pro.

I reverted back to IE8 64-bit edition and the same problem exists.

As suggested in the previous post, I tried with HTML4 and it worked. I didn't think I had to go back so far.

Thanks,

Daniel

Re: Plupload & IE9 64-bit: no compatible runtimes?

Wait!

I just noticed that the Flash Player "Square" preview release with native 64-bit support (http://labs.adobe.com/technologies/flas … 10/square/) works with IE8 64-bit edition.

Daniel

Re: Plupload & IE9 64-bit: no compatible runtimes?

Do you really need to use the 64-bit version? There isn't much of an upside to using that right now, and your system should still have the 32-bit versions installed.

8 (edited by dfrechette 2011-01-13 14:26:42)

Re: Plupload & IE9 64-bit: no compatible runtimes?

Afraithe,

I did not explicitly choose to install the 64-bit version. It's was automatically selected for me based on my system config. I simply clicked on the big download button and installed the software.

Anyway, I uninstalled IE9 now. However, this does not solve the compatibility issue with the add-ons. Only the HTML4 runtime works in IE9 for the moment.

Daniel

9 (edited by dfrechette 2011-01-14 13:54:33)

Re: Plupload & IE9 64-bit: no compatible runtimes?

I was not aware that the 64-bit version of IE9 also came with a 32-bit version.

Everything is working fine now using the 32-bit version.

So, the conclusion is that Microsoft created a mess with 32/64-bit apps and users are left to figure out by themselves that the 32-bit version works better than the 64-bit in the case of IE. It's a disappointing situation.

Daniel

Re: Plupload & IE9 64-bit: no compatible runtimes?

One big problem is that there is no 64-bit version of the Flash plugin, otherwise that runtime should work fine.